Archives

phaさんのEasyBotterのアイディアをヒントに、新しいphpのプログラムを作ってみました。

皆さん、こんばんは。

phaさんのEasyBotterは、自動ツイートのプログラムで有名ですが、

私も、そのプログラムのアイディアをヒントに、自分でも作ってみました。

EasyBotterは多機能ですが、私の作ったのはそこまで多機能ではありません。

1行、1行、自動ツイートの文章を集めたデーターを読み込んでは、グルグルと回す手法ですね。

いいアイディアだなと思って、私も独自に作ってみましたが、なんとか出来ました。

tmhOAuthのプログラムも使っているので、画像も自動でアップできます。

phaさんと、tmhOAuthの作者に、この場を借りて御礼を申し上げます。

phaさん、tmhOAuthの作者の方。どうも有り難うございました。

毎時、55分に、私の作った文章のテキストを、自動でツイートします。

それでは、皆さん、オヤスミナサイ。

プラグイン”Exec PHP”を使って、WordPressで使っているPHP、MySQLのバージョンを表示する方法。

皆さん、こんにちは。

WordPressでも、PHPやMySQLのバージョンを表示できます。
PHPのプログラムを使う前に、Exec PHPというプラグインをダウンロードして有効にしておきましょう。

外観→ウィジェット→テキストの順番に選択し、
中のプログラムを、下記のようにして使ってみましょう。

[crayon]

/ MySQL er 8.0.22-0ubuntu0.20.04.3 for Linux on x86_64 ((

[/crayon]

私は、Linux Mint 19 Taraなので、これでうまく動きました。
まだ、出来たばかりで、他のバージョンのPHP,MySQLを試しておりませんので、
今後手直しが入る可能性もあります。
それでは、ごきげんよう。

Linux Mint 13 Mayaにapache2と、mysqlと、phpをインストールする方法。

[crayon]
$ su
# apt-get udpate
# apt-get dist-upgrade
# apt-get install apache2 mysql-server
[/crayon]
で、apache2とmysqlはインストールされます。
既にバージョンは古めですが、PHP5.2.10をインストールする方法は、次の通りです。

http://thanks.linuxparadise.net/modules/d3downloads/index.php?page=singlefile&cid=2&lid=3

から、karmic.listと、php52.txtをダウンロードする。

/etc/apt/sources.list.d/

に、karmic.listを入れて(ファイル名を”karmic.list”にし、このファイルをダウンロードしてご利用ください。上記サイトと内容は一緒です。)

/etc/apt/preferences.d/

に、php52.txtを入れて(ファイル名を”php52″にし、このファイルをダウンロードしてご利用ください。上記サイトと内容は一緒です。)

そして、下記を実行します。
[crayon]
# apt-get update
# apt-get install php5 php5-common php5-gd php5-cli php5-curl php5-dev php5-mysql php5-mcrypt php-pear
[/crayon]
これで、PHP5.2.10がインストールされます。
PHP5.4.23をインストールする方法は、少し違います。OSがLinux Mint 13 Mayaの場合には、次の通りにします。
[crayon]
# rm  /etc/apt/preferences.d/php52
# rm  /etc/apt/sources.list.d/karmic.list
# add-apt-repository ppa:ondrej/php5-oldstable
# apt-get update
# apt-get install php5 php5-common php5-cli php5-dev php5-gd php5-curl php5-mysql php5-mcrypt php-pear
# php -v

PHP 5.4.23-1+sury.org~precise+1 (cli) (built: Dec 12 2013 09:24:16)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
with eAccelerator v1.0-dev, Copyright (c) 2004-2012 eAccelerator, by eAccelerator
[/crayon]
これで、おk。私の場合には、eAcceleratorがインストールされているので、その表示もされます。PHP5.4.23用の、eAcceleratorのインストール方法は、

http://linuxparadise.net/?p=74 です。

apache2の細かい設定などは省略します。しかしながら、この基本のapache2、mysql、PHP5.2.10またはPHP5.4.23がインストールされていれば、XOOPSもWORDPRESSも動くはずですよ。

お試しあれ。